Квадратные скобки в формуле excel

Квадратные скобки в формуле excel

трюки • приёмы • решения

Эта статья содержит описание некоторых способов применения формул в таблицах. В примере используется простая таблица суммы итоговых значений продаж с тремя столбцами, содержащими сведения о месяце, прогнозируемом показателе и фактическом значении (Месяц, По плану и Реальный показатель), как показано на рис. 160.1.

Я ввел данные, а затем преобразовал диапазон в таблицу с помощью команды Вставка ► Таблицы ► Таблица. Обратите внимание на то, что я не определял никаких имен, а область данных в таблице названа Таблица1 по умолчанию.

Рис. 160.1. Простая таблица стремя столбцами

Работа с итоговой строкой

Если вы хотите вычислить итоговое прогнозируемое и итоговое фактическое значение продаж, вам даже не нужно писать формулы. Просто нажмите кнопку добавления строки итоговых формул в таблицу.

  1. Активизируйте любую ячейку в таблице.
  2. Выполните команду Работа с таблицами ► Параметры стилей таблиц и установите флажок Строка итогов.
  3. Активизируйте ячейку в строке итогов и выберите результирующую формулу в раскрывающемся списке (рис. 160.2).

Например, для расчета суммы значений столбца Реальный показатель выберите Сумма в раскрывающемся списке в ячейке D15 . Excel создаст следующую формулу:
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(109;[Реальный показатель]) .

Для функции ПРОМЕЖУТОЧНЫЕ.ИТОГИ 109 является перечисленным аргументом, который представляет сумму. Второй аргумент функции ПРОМЕЖУТОЧНЫЕ.ИТОГИ — это имя столбца в квадратных скобках. Использование названий столбцов в квадратных скобках — способ создания структурированных ссылок внутри таблиц.

Рис. 160.2. Раскрывающийся список позволяет вам выбрать результирующую формулу для столбца таблицы

Вы можете включать/отключать отображение итоговой строки, устанавливая/снимая флажок Строка итогов в группе Работа с таблицами ► Параметры стилей таблиц. Если отключить ее, то результирующие настройки, которые вы выбрали, запоминаются до следующего включения.

Использование формул внутри таблицы

Часто необходимо использовать формулы в таблице. Например, в таблицу, показанную на рис. 160.1, можно добавить столбец, который показывает разницу между фактическим и прогнозируемым значением за каждый месяц. Как вы увидите. Excel существенно упрощает этот процесс.

  1. Активизируйте ячейку Е2 и введите Разница в заголовок столбца. Excel автоматически расширит таблицу.
  2. Перейдите к ячейке Е3 и введите знак равенства, обозначающий начало формулы.
  3. Щелкните на левой стрелке, указав на соответствующее значение н столбце Реальный показатель.
  4. Введите знак минус (-), а затем щелкните два раза на левой стрелке, указывающей на соответствующее значение в столбце По плану.
  5. Нажмите Enter, чтобы завершить формулу (рис. 160.3).

Формула вводится в другие ячейки столбца, и строка формул отображает ее:
=[@[Реальный показатель]]-[@[По плану]]

Рис. 160.3. Столбец Разница содержит формулу

Хотя формула была введена в первую строку таблицы, так делать необязательно. Всякий раз, когда формула вводится в пустой столбец таблицы, она распространяется на другие ячейки в столбце. Если вам нужно изменить формулу, отредактируйте любую формулу в столбце, и изменение применится к другим его ячейкам.

Распространение формулы на другие ячейки столбца таблицы — это одна из возможностей автоматической замены в Excel. Чтобы отключить эту функцию, щелкните на значке, который появляется, когда вы вводите формулу, и выберите Не создавать вычисляемые столбцы автоматически.

Ранее в этой статье для создания формулы применялись имена столбцов. Однако вы можете ввести формулу, используя стандартные ссылки на ячейки. Например, попробуйте ввести следующую формулу в ячейку Е3: =D3-C3 . Если ввести ссылки на ячейки, то Excel по-прежнему автоматически скопирует формулу в другие ячейки столбца.

Ссылки на данные в таблице

Формулы, которые находятся за пределами таблицы, могут ссылаться на данные внутри таблицы, используя ее имя и заголовки столбцов. Вам не нужно создавать названия для этих элементов. Сама таблица имеет название (например, Таблица1), и вы можете ссылаться на данные в ней с помощью заголовков столбцов.

Вы можете, конечно, использовать стандартные ссылки на ячейки, чтобы обращаться к данным в таблице, но ссылки на таблицу имеют явное преимущество: имена настраиваются автоматически, если размер таблицы изменяется вследствие добавления или удаления строк.

Обратитесь к таблице, показанной на рис. 160.1. Ей было присвоено имя Таблица1 при создании. Для вычисления суммы всех данных в таблице укажите такую формулу: =СУММ(Таблица1) . Эта формула всегда возвращает сумму всех данных, даже если строки или столбцы добавляются или удаляются. Если же вы измените название Таблица1, Excel автоматически откорректирует формулы, которые ссылаются на нее. Например, если переименовать Таблица1 в AnnualData (используя Диспетчер имен), предыдущая формула изменится так: =СУММ(Annual Data) .

Во многих случаях нужно обратиться к конкретному столбцу в таблице. Следующая формула возвращает сумму данных столбца Реальный показатель (но игнорирует итоговую строку): =СУММ(Таблица1[Реальный показатель]) . Обратите внимание, что имя столбца заключено в квадратные скобки. Снова формула автоматически подстраивается, если вы изменяете текст в заголовке столбца.

Что еще лучше, Excel оказывает помощь при создании формулы, которая ссылается на данные в таблице. На рис. 160.4 продемонстрирована работа функции автоматического заполнения формулы, помогающей создавать формулу, показывая список элементов в таблице.

Рис. 160.4. Формула автозаполнения полезна при создании формулы, которая относится к данным в таблице

Ранее я уже посвятил несколько заметок использованию формул массива:

Полученные комментарии подсказали мне, что пользователи не часто используют формулы массива. Более того мало кто знаком с ними.

Предлагаю вашему вниманию посвященный массивам фрагмент книги Джона Уокенбаха. Подробное руководство по созданию формул в Excel 2002. – М.: Издательский дом «Вильямс», 2002. – 624 с.

Читайте также:  Рынок аксессуаров для мобильных телефонов

Скачать заметку в формате Word, примеры в формате Excel

В Excel массивы могут быть одномерными (их еще называют векторами) или двумерными (матрицы). Размерность массива зависит от количества строк и столбцов в нем. Например, одномерный массив может храниться в диапазоне, состоящем из одной строки (горизонтальный массив) или столбце (вертикальный массив). Двумерный массив хранится в прямоугольном диапазоне ячеек. Excel (в отличие от языка программирования VBA) не поддерживает трехмерные массивы.

Однако, как будет показано далее, массивы вовсе не обязательно хранить в ячейках. Можно производить операции над массивами, которые существуют только в памяти Excel. Можно применять формулы массива для выполнения операций и получения результатов вычислений. Сама формула массива может находиться во многих ячейках или в одной единственной. Существует два вида формул массива: формула массива, которая возвращает несколько значений, и другая, которая возвращает только одно значение.

Формула массива, возвращающая несколько значений

Рис. 1 демонстрирует рабочий лист, на котором производится расчет объема продаж товаров. Для этого вычисляют значение в столбце D (объем продаж каждого товара), используя формулу =В2*С2, а затем копируют ее в расположенные ниже ячейки.

Рис. 1. Диапазон D2:D6 содержит традиционные формулы произведения (в ячейках D2 и D3 различные формулы, хотя и похожие)

После копирования этой формулы рабочий лист содержит пять формул в столбце D. Альтернативный путь вычислений – использование единой формулы (формулы массива) для вычисления всех пяти значений в диапазоне D2:D6. Эта единственная формула занимает пять ячеек и возвращает массив из пяти значений. Для создания единой формулы массива нужно произвести следующие операции:

  1. Выделить диапазон, в котором будет сохраняться результат вычислений. В данном случае это диапазон D2:D6.
  2. Ввести формулу: =В2:В6*С2:С6
  3. Обычно после введения формулы нажимается клавиша , но только не в случае формулы массива. Так как введенная формула является формулой массива, нажимается комбинация клавиш .

Формула добавляется во все пять выделенных ячеек (рис. 2), при этом в строке формул появится следующее выражение:

Рис. 2. Диапазон D2:D6 содержит формулу массива (в ячейках D2 и D3 одна и та же формула)

Excel заключил формулу в фигурные скобки. Это говорит о том, что данная формула является формулой массива.

Эта формула производит вычисления и возвращает массив из пяти элементов. В данном случае формула массива производит операции над двумя другими массивами, оба из которых хранятся в диапазонах ячеек. Значения первого массива хранятся в диапазоне В2:В6, а второго — в С2:С6. Для отображения итогового массива требуется пять ячеек, потому что в одной ячейке нельзя отобразить более чем одно значение. Этим объясняется, зачем нужно выделять пять ячеек перед введением формулы.

Конечно, эта формула массива возвращает точно такие же значения, что и пять формул, введенных в соответствующие ячейки диапазона D2:D6

Использование единой формулы массива предпочтительнее, чем использование нескольких формул, так как предоставляет определенные преимущества:

  • Легко убедиться, что все формулы в диапазоне идентичны.
  • Использование формул массива, возвращающих сразу несколько значений, избавляет от случайных изменений в формуле. Нельзя просто изменить одну ячейку в формуле массива.
  • Использование формул массива почти всегда предотвращает вмешательство начинающих пользователей, которые хотят внести свои изменения в формулы.

Формула массива, возвращающая одно значение

Обратимся к рис. 3. Следующая формула массива размещается в одной ячейке – D8:

Рис. 3. Сумма произведений в виде формулы массива

Эту формулу можно ввести в любую ячейку. При вводе формулы не нужно использовать фигурные скобки, а после введения не забудьте использовать комбинацию клавиш .

Эта формула массива возвращает общую сумму, на которую продано товаров. Важно понимать, что значение, возвращаемое этой формулой, не зависит от информации в столбце D. Фактически можно удалить столбец D, а формула будет выполняться по-прежнему.

Эта формула оперирует значениями, находящимися в двух массивах. Оба массива хранятся в ячейках. Первый – в диапазоне ячеек В2:В6, второй – C2:С6. Формула перемножает соответствующие значения в этих двух массивах и создает новый массив (который существует только в памяти компьютера). Функция СУММ выполняет операцию над этим новым массивом и возвращает значение суммы его элементов.

Создание массива констант

В предыдущих примерах использовались массивы, хранящиеся в диапазоне ячеек рабочего листа. Но… массив не обязательно должен храниться в диапазоне ячеек. Массив, который хранится исключительно в памяти, называется массивом констант.

Для создания массива констант нужно список его элементов заключить в фигурные скобки. Вот пример горизонтального массива констант, состоящего из пяти элементов: <1;0;1;0;1>. Для создания вертикального массива констант используйте в качестве разделителя двоеточие.

Формула =СУММ(<1;0;1;0;1>) использует функцию СУММ, аргументом которой является массив констант. Формула возвращает значение суммы элементов массива, равное 3. Отметим, что эта формула использует массив в качестве аргумента, но при этом не является формулой массива. Поэтому не нужно использовать клавиши для ввода формулы.

В случае непосредственного задания массива (как показано выше) необходимо заключать элементы массива в фигурные скобки. С другой стороны, при вводе формулы массива фигурные скобки не ставятся.

Пока, возможно, трудно заметить, какие-либо преимущества использования массивов констант. Действительно, формула =СУММ(1;0;1;0;1) возвращает точно такое же значение, как и =СУММ(<1;0;1;0;1>).

Читайте также:  Приложение для кеша песен из вк

Очевидные преимущества становятся ясны при дальнейшем рассмотрении. Следующая формула использует два массива констант: =СУММ(<1;2;3;4>*<5;6;7;8>). Эта формула создает в памяти новый массив, который состоит из произведения соответствующих элементов двух других массивов: <5;12;21;32>. Созданный массив используется впоследствии в качестве аргумента для функции СУММ, которая возвращает результат вычислений (70). Формула эквивалентна следующей формуле, которая не использует массивы: =СУММ(1*5;2*6;3*7;4*8)

Можно составлять формулы массивов для разных типов массивов. Например, можно составить формулу, в которой будет одновременно использоваться массив констант и массив, элементы которого хранятся в диапазоне ячеек (рис. 4). Для подсчета суммы значений, которые являются произведением элементов массива в диапазоне Al:D1 и соответствующих элементов массива констант, применяется следующая формула: =<СУММ((A1:D1*<1;2;3;4>)>. Эта формула эквивалентна следующей: =СУММ(А1*1;В1*2;С1*3;D1*4)

Рис. 4. Сумма произведений массива рабочего листа и массива констант

Элементы массива констант

Массивы констант могут состоять из чисел, текста, логических значений (например, ИСТИНА, ЛОЖЬ) и даже значений ошибок, таких как #Н/Д. Числа в массиве могут быть целыми, с десятичной точкой или экспоненциальными. Текст в массиве констант заключается в двойные кавычки (например, " Вторник " ). Массив констант может состоять из элементов разного типа, например:

Массивы констант не могут включать в себя формулы, функции или другие массивы. Числовые значения не могут включать символы доллара, точки с запятой (точки), круглые скобки или символ процента. Например, неверный массив констант:

Понятие размерности массива

Массивы могут быть одномерными или двумерными. Ориентация одномерного массива может быть горизонтальной или вертикальной.

Одномерные горизонтальные массивы

Элементы в одномерном горизонтальном массиве разделяются точкой с запятой (запятыми в английской версии программы). Ниже приведен пример одномерного горизонтального массива констант:

Для отображения этого массива в диапазоне необходимо пять последовательных ячеек в строке. Чтобы ввести этот массив в диапазон, выделите диапазон ячеек, состоящий из одной строки и пяти столбцов. Затем введите: = <1;2;3;4;5>и нажмите (рис. 5).

Рис. 5. Одномерный горизонтальный массив.

Обратите внимание, внутренние фигурные скобки обозначают массив констант; внешние фигурные скобки – формулу массива. Если ввести этот массив в горизонтальный диапазон, состоящий более чем из пяти ячеек, то лишние ячейки будут содержать #Н/Д (что указывает на недопустимые значения). Если ввести этот массив в вертикальный диапазон ячеек, то в каждой ячейке диапазона появится первый элемент (1) массива.

Ниже приведен пример другого горизонтального массива. Он состоит из семи элементов и создает текстовую последовательность: < " Понедельник " ; " Вторник " ; " Среда " ; " Четверг " ; " Пятница " ; " Суббота " ; " Воскресенье " >. Для ввода этого массива выделите семь элементов в строке и введите следующий текст: =< " Понедельник " ; " Вторник " ; " Среда " ; " Четверг " , " Пятница " ; " Суббота " ; " Воскресенье " >. Нажмите .

Одномерные вертикальные массивы

Элементы в одномерном вертикальном массиве разделяются двоеточием (точкой с запятой в английской версии программы). Ниже приведен пример вертикального массива констант, состоящего из шести элементов: <10:20:30:40:50:60>. Для отображения этого массива в диапазоне необходимо шесть ячеек в столбце. Чтобы ввести этот массив в диапазон, выделите диапазон ячеек, состоящий из шести строк и одного столбца. Затем введите: = <10:20:30:40:50:60>и нажмите .

Ниже приведен пример другого вертикального массива, состоящего из четырех элементов:

Двумерные массивы

В двумерных массивах используются точки с запятыми (запятые в английской версии программы) для разделения горизонтальных элементов и двоеточия (точки с запятой в английской версии программы) для разделения вертикальных элементов. Ниже приведен пример массива констант размерностью 3×4: <1;2;3;4:5;6;7;8:9;10;11;12>. Для отображения этого массива в диапазоне требуется двенадцать ячеек. Чтобы ввести этот массив в диапазон, выделите диапазон ячеек, состоящий из трех строк и четырех столбцов. Затем введите следующую формулу = <1;2;3;4:5;6;7;8:9;10;11;12>после чего нажмите (рис. 6).

Рис. 6. Двумерный массив

Если ввести массив в диапазон, состоящий из большего числа ячеек, Ехсеl отобразит #Н/Д в лишних ячейках (рис. 7).

Рис. 7. Показано, что получится, если ввести массив 3×4 в диапазон ячеек 10×5.

Каждая строчка двумерного массива должна содержать одинаковое количество элементов. Например, представленный ниже массив недопустимый, потому что его третья строка состоит только из трех элементов; <1;2;3;4:5;6;7;8:9;10;11>. Excel не даст возможности ввести формулу, в которой присутствует недопустимый формат массива.

Присвоение имени массивам констант

Excel позволяет создать массив констант, присвоить ему имя и затем использовать это имя в формулах. Фактически присвоение имени массиву заключается в присвоении имени формуле (рис. 8). Пройдите по меню: Формулы – Диспетчер имен.

Рис. 8. Показано, как присвоить имя массиву, используя диалоговое окно Создание имени.

Массиву присвоено имя ДеньНедели, которое соответствует следующему массиву констант: < " Понедельник " ; " Вторник " ; " Среда " ; " Четверг " ; " Пятница " ; " Суббота " ; " Воскресенье " >. Отметим, что в диалоговом окне Создание имени для задания массива необходимо использовать знак равенства (=) перед массивом констант. В противном случае массив будет воспринят как текстовая строка. Также необходимо самостоятельно взять элементы массива в фигурные скобки. Excel в этом случае не вводит скобки автоматически. После присвоения имени массиву, его имя можно использовать в формулах (рис. 9).

Читайте также:  Программа для работы с почтой на русском

Рис. 9. Ввод поименованного массива в диапазон Al:G1

Так как элементы массива разделяют точки с запятой, ориентация массива будет горизонтальной. Для создания вертикальных массивов используются двоеточия. Также можно воспользоваться функцией транспонирования для того, что бы вставить горизонтальный массив в вертикальный диапазон (рис. 10). Для этого введите в диапазон семи вертикальных ячеек A1:A7 формулу массива:

Рис. 10. Ввод горизонтального массива в вертикальный диапазон

При использовании функции Excel ИНДЕКС можно получить доступ к отдельному элементу массива. Например, ниже приведенная формула возвращает значение «Четверг», четвертого элемента массива ДеньНедели: =ИНДЕКС(ДеньНедели;4)

При работе с электронными таблицами Excel возникают ситуации, когда при открытии книги столбцы вместо привычных латинских букв имеют в качестве заголовков числа. Происходит это из-за того, что в Excel используется два вида ссылок: А1 и R1C1. Рассмотрим оба стиля и выясним, чем они отличаются, и как отключить стиль R1C1.

Адрес ячейки

Название стиля R1С1 происходит от двух английских слов R— row (строка), C — column (столбец).

В стиле А1 ячейка имеет адрес A1, где А — столбец, а 1 — номер строки. В стиле R1C1 — адрес R1C1, где R1 указывает номер строки, а C1 — номер столбца. Т.е. ячейке С2 одного стиля будет соответствовать ячейка R2C3 (вторая строка, третий столбец).

Формулы

Чем же отличается использование этих стилей при вычислениях? Рассмотрим следующий пример. Дана таблица, состоящая из трех числовых значений. Нужно посчитать сумму этих ячеек.

Сравним формулы, которые получаются при работе с таблицей в A1 и R1C1-стилях.

Для сравнения активируем режим отображения формул: вкладка ФормулыПоказать формулы (удобно, если нужно посмотреть сразу на все формулы в ячейках, а не на результаты).

В формулу A1-стиля входят адреса ячеек, значения которых складываются: B3, B4 и C3.

В R1C1-стиле сумма значений ячеек, соответствующих ячейкам примера с A1-стилем, имеет другой вид. В формулу не входят адреса ячеек. Каждое слагаемое указывает, на сколько строк и сколько столбцов происходит смещение ссылки относительно ячейки, в которую вводится формула. Если число в скобках положительно, то ссылка смещается вправо или вниз, если отрицательно — влево или вверх. Все зависит от того, после чего стоит это число: R — смещение строки, C — смещение столбца. Если числа нет, то нет и смещения.

Рассмотрим детально каждое слагаемое:

  • R[-1]C[-1] — ссылка на ячейку, которая расположена на одну строку выше (R — строка, [-1] — смещение вверх) и на один столбец левее (C — столбец, [-1] — смещение на 1 столбец влево). Т.к. формула вводится в ячейку R4C3 (или С4 для A1-стиля), то с учетом смещения мы получим ячейку R3C2. Эта ячейка соответствует ячейке B3 A1-стиля.
  • RC[-1] — ссылка расположена в той же строке, что и формула (нет смещения строки), столбец смещен влево на один (-1). Это ячейка B4A1-стиля.
  • R[-1]C — ссылка смещена на одну строку вверх (-1) и находится в том же столбце. Это ячейка C3A1-стиля.

Таким образом, в формуле число в скобках R1C1-стиля показывает смещение строки или столбца относительно ячейки с формулой. В A1-стиле в формулу входят целевые ячейки, в которых расположены данные.

Относительные, абсолютные и смешанные ссылки

При вычислениях в таблице Excel используются относительные, абсолютные и смешенные ссылки.

  • Относительные ссылки при копировании формулы меняются. В A1-стиле относительные ссылки записываются как G3, D5 и т.д. В R1C1-стиле R[4]C[2], R[6]C[-1] и т.д. Числа, указывающие на смещение, заключаются в квадратные скобки. RC — ссылка на текущую ячейку (смещение равно нулю).
  • Абсолютные ссылки при копировании не изменяются. В A1-стиле абсолютные ссылки записываются как $G$3, $D$5 и т.д. В R1C1-стиле R4C2, R6C1 и т.д. Числа, указывающие на смещение, не заключаются в квадратные скобки.
  • Смешанные ссылки — ссылки вида $G3, D$5 и т.д. При копировании не меняется только часть ссылки, стоящая после знака $. В R1C1-стиле R4C[2], R[6]C5 и т.д.

Как включить или отключить R1C1-стиль в Excel

Если Вы используете Excel 2003, то выберите СервисПараметры — вкладка Общие. Для включения стиля R1C1 устанавливаем флажок Стиль ссылок R1C1. Для выключения — флажок снимаем.

Для более поздних версий программы (Excel 2007, 2010 и далее) нажимаем кнопку Офис (или Файл) — Параметры ExcelФормулы — устанавливаем флажок Стиль ссылок R1C1. Для выключения — флажок снимаем.

R1C1-стиль удобен при работе с большими таблицами для сравнения формул в ячейках и поиска ошибок.

Кратко об авторе:

Шамарина Татьяна Николаевна — учитель физики, информатики и ИКТ, МКОУ "СОШ", с. Саволенка Юхновского района Калужской области. Автор и преподаватель дистанционных курсов по основам компьютерной грамотности, офисным программам. Автор статей, видеоуроков и разработок.

Спасибо за Вашу оценку. Если хотите, чтобы Ваше имя
стало известно автору, войдите на сайт как пользователь
и нажмите Спасибо еще раз. Ваше имя появится на этой стрнице.

Есть мнение?
Оставьте комментарий

Понравился материал?
Хотите прочитать позже?
Сохраните на своей стене и
поделитесь с друзьями

Вы можете разместить на своём сайте анонс статьи со ссылкой на её полный текст

Ссылка на основную публикацию
Каких в списках нет в текстовой редактор
607650 Нижегородская обл., г.Кстово, ул.Школьная, д.15 Администратор сайта: Е.И.Романова При использовании материалов сайта ссылки на сайт и авторов обязательны ©...
Как упорядочить закладки в яндекс
Интернет многообразен. Сотни тысяч веб-сайтов с самым разнообразным контентом посещаются пользователями ежедневно. Вне зависимости от целей — познавательных, развлекательных или...
Как ускорить ноутбук асус на виндовс 10
Многие владельцы ПК и ноутбуков привыкли к седьмой версии операционной системы Windows и никак не хотят переходить на "десятку". А...
Каков диаметр пылинки википедия
Пыль — мелкие твёрдые частицы органического или минерального происхождения. К пыли относят частицы меньшего диаметра от долей микрона и до...
Adblock detector